ShipStation Login Issues
Incident Report for ShipStation
Resolved
After closely monitoring this situation, we have confirmed that the case is now resolved.

The issue was related to certain internet service providers accessing AWS servers, which limited user access to the internet and in turn ShipStation.

Thank you for your patience!
Posted Sep 10, 2024 - 03:02 CDT
Update
We are continuing to investigate this issue.
Posted Sep 09, 2024 - 23:36 CDT
Investigating
ShipStation is aware of the technical issues impacting the ShipStation Platform. We are actively working to resolve this issue.
We will provide updates as they become available to us. Thank you for your patience!
Posted Sep 09, 2024 - 20:18 CDT
This incident affected: ShipStation.