Account Login/Performance Issues
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Jun 04, 2021 - 10:34 CDT
Identified
We are seeing some login and performance issues with specific accounts this morning. The underlying issue has been identifying and we are working to clear that up now.
Posted Jun 04, 2021 - 09:42 CDT
This incident affected: ShipStation.