Degraded performance for Stamps.com & Endicia services
Incident Report for ShipStation
Resolved
This incident has been resolved and systems are operational. Thanks for your patience on this matter!
Posted May 15, 2020 - 13:29 CDT
Update
We are continuing to investigate this issue.
Posted May 15, 2020 - 12:19 CDT
Investigating
We are aware of and currently investigating reported issues related to label creation for Stamps.com & Endicia services. We will provide updates as they are available and apologize for any inconvenience. The Stamps.com & Endicia status pages can be found here: https://status.stamps.com/ &
https://status.endicia.com/incidents/cl68bdsh4nth
Posted May 15, 2020 - 12:18 CDT
This incident affected: Carriers (Stamps.com).