DHL Express label creation and rate issues
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 17:45 CST
Monitoring
We have seen the DHL services returning to normal functionality. We are continuing to monitor this to confirm the resolution of this incident.
Posted Nov 05, 2019 - 16:56 CST
Identified
DHL Express has confirmed that they are aware of the issue and are working to address the underlying causes. We will update this once we have more information.
Posted Nov 05, 2019 - 15:26 CST
Investigating
We are currently investigating an issue where users are unable to create labels or get rates for DHL Express shipments.
Posted Nov 05, 2019 - 13:30 CST
This incident affected: Carriers (DHL Express).